mardi 30 octobre 2012

NB.SI - Fonction d'Excel

Ou comment compter à partir d'une condition!!!!


Exemples pour la fonction NB.SI.
La fonction NB.SI compte le nombre de cellules d’une plage qui répondent à un critère que vous avez spécifié.


Syntaxe:
=NB.SI(plage, critères)

-Plage :  Obligatoire. Représente un certain nombre de cellules à compter, y compris des nombres ou des noms, des matrices ou des références qui contiennent des nombres. Les valeurs vides et textuelles seront ignorées.

-Critères  :  Obligatoire. Nombre, expression, référence de cellule ou chaîne de texte qui détermine les cellules à compter.


Dans notre exemple nous souhaitons connaître les cours les plus suivis par nos élèves.
Nous avons un tableau qui récapitule les élèves et les cours, ainsi que les informations de présence (P) ou d'absence (A).
Pour connaître les cours les plus suivis nous utilisons la fonction NB.SI, avec P et A comme critères, avec comme plage les colonnes des cours.














Nous nous plaçons en C16 dans notre tableau pour taper notre formule =NB.SI(C3:C15;"P")












Nous nous plaçons en C17 dans notre tableau pour répéter l'opération pour les absents =NB.SI(C3:C15;"A"). Un Copier/Coller plus tard nous obtenons notre tableau.














Nous pourrions également définir des cellules contenant les critères et aller chercher l'information  directement à partir de la formule.







Si vous souhaitez voir l'exemple sous Excel vous pouvez télécharger le fichier ici.

0 commentaires :

Enregistrer un commentaire