mercredi 17 décembre 2014

Excel - Fonctions logiques ET/OU

Fonction Excel - ET/OU - Formule logique

L'utilisation d'Excel ne se limite pas à des opérations comme les additions, les soustractions, les multiplications ou les divisions.
La plus part du temps la comparaison entre différents éléments d'un tableau ou d'une base de données est nécessaire voir impérative. Cette action passe le plus souvent par la fonction SI, mais pas que, dans certains cas l'adjonction de nouveaux opérateurs est indispensable. Nous allons voir aujourd'hui l'intérêt des fonctions ET et OU.

D'abord un point rapide.

-ET: Vérifie si toutes les conditions à comparer sont vraies et renvoie VRAI ou FAUX.

Syntaxe ET(valeur_logique1;valeur_logique2;...)
valeur_logique1,valeur_logique2, ... représentent les conditions à remplir. Il est possible de saisir jusqu'à 255 conditions.

-OU: Vérifie si au moins une condition est vraie et renvoie VRAI ou FAUX.

Syntaxe OU(valeur_logique1;valeur_logique2;...)
valeur_logique1,valeur_logique2, ... représentent les conditions à remplir ou pas. Il est possible de saisir jusqu'à 255 conditions.


Nous avons le tableau suivant, reprenant les prénoms, le sexe et l’âge d'un groupe d'adolescents.
Je prends volontairement un exemple faisant appel aussi bien à du texte qu'à des valeurs, ainsi nous pouvons voir que ces fonctions ne sont limitées à des valeurs.



Nous voulons extraire plusieurs informations de notre tableau:

-Savoir quelle fille à un âge supérieur à la moyenne de l'ensemble.
Dans ce cas, nous devons vérifier que deux conditions soient vraies, sexe = F et Age > à 20. Nous entrons la formule suivante dans la cellule E3, =SI(ET(C3="F";D3>$D$9);"Oui";"Non") et ensuite nous la dupliquons jusqu'à E8.



-Savoir quel adolescent est une fille ou a un âge supérieur à la moyenne.
Dans ce cas, nous devons vérifier qu'une de deux conditions, sexe =F ou Age > à Moyenne, est vraie. Nous entrons la formule suivante dans la cellule F3, =SI(OU(C3="F";D3>$D$9);"Oui";"Non") et ensuite nous la dupliquons jusqu'à F8.



-Savoir quelle fille ou garçon a un âge supérieur à la moyenne.
Dans ce cas la fonction SI suffit, =SI(D3>$D$9;"Oui";"Non"), j'aurais pu entrer aussi =SI(ET(OU(C3="F";C3="M");D3>$D$9);"Oui";"Non") pour obtenir le même résultat mais on ne va pas non plus se compliquer la vie. Sachez seulement qu'il est possible d'imbriquer ET et Ou.



J'ai deux questions à vous poser.

Si nous rajoutons une colonne contenant la moyenne des notes.



-Quel garçon ayant un âge supérieur à la moyenne de l'ensemble, a une moyenne de note au moins égale à 12?
-Quel fille n'a pas un âge supérieur à la moyenne de l'ensemble et n'a pas une moyenne de note au moins égale à 12?

Indiquez le nom, mais aussi la formule utilisée.

En savoir plus sur les fonctions logiques? Retrouvez les 50 formules Excel de base.

Maîtriser Excel, c'est facile !!!

En discuter sur le Forum?

Print Friendly and PDF


Restez informé, abonnez-vous à la newsletter, entrez votre adresse mail:


Delivered by FeedBurner
Pays/territoire : Bry-sur-Marne, France

0 commentaires :

Enregistrer un commentaire