mercredi 10 décembre 2014

Excel - La fonction RECHERCHE

Fonction Excel - RECHERCHE - Formule recherche et référence.


Vous connaissez surement les fonctions RECHERCHEV et RECHERCHEH dans Excel et vous devez même les utiliser assez souvent dans vos fichiers et tableaux pour retrouvez dans des tables des valeurs ou textes à réutiliser par la suite dans vos travaux.
Mais connaissez vous la fonction RECHERCHE. Dans certains cas ou les deux autres fonctions sont inutilsables, RECHERCHE peut vous aider.

Cette fonction offre deux possibilités:
-Une recherche matricielle.
-Une recherche vectorielle.

Nous allons voir un exemple d'utilisation pour chaque possibilité, ceux-ci ne sont pas exhaustifs et il doit exister beaucoup d'autres possibilités d'utiliser cette fonction.

Recherche Matricielle

RECHERCHE (valeur_cherchée,matrice)

La forme matricielle de recherche, cherche dans la première ligne ou colonne d'un tableau pour la valeur spécifiée, puis renvoie une valeur à partir de la même position dans la dernière ligne ou colonne de la matrice.

Avec un exemple ce sera plus parlant.
Imaginons que nous ayons la liste suivante, correspondant à des clients grandes surfaces.

CORA Lille
AUCHAN Lyon
CASINO Nancy
AUCHAN Nantes
CORA Toulouse
CASINO Lyon

D'un autre coté, nous avons la liste des grandes surfaces (je ne fais pas de pub, les pubs c'est en bas ou à droite) avec les taux de commissions applicables aux ventes réalisées avec chacune d'elles.

Clients Taux Com.
AUCHAN  10%
CASINO 12%
CORA 11%

Et enfin nous avons un tableau récapitulatif des ventes réalisées par nos vendeurs avec nos différents clients.


Nous voulons calculer pour chacun de nos vendeurs le montant de commission que nous devons lui verser en fonction du client avec lequel il à réalisé son CA.

Pour réaliser notre calcul nous devons arriver à extraire de la liste clients du tableau les noms des grandes surfaces. Inutile d'essayer avec RECHERCHEV, la fonction ne parviendra pas à trouver la correspondance entre les deux listes à notre disposition.
Nous allons utiliser RECHERCHE, qui dans ce cas s'avère être une excellente solution, car elle va extraire le premier mot d'une suite termes, qu'elle va ensuite comparer à une liste existante.

Commencons par entrer  =RECHERCHE(B3;$B$11:$B$13) dans la première cellule de la colonne taux, qui va chercher B3 (CORA Lille) dans la liste B11 à B13, et nous obtenons CORA (Magique!!!). Ensuite nous Complétons notre formule avec RECHERCHEV, =RECHERCHEV(RECHERCHE(B3;$B$11:$B$13);$B$11:$C$13;2) afin d'obtenir notre taux de commission de 11%.

Une fois notre formule répétées dans les cellules suivantes notre tableau est complet et correcte.


Petite précision qui a son importance, la table ou liste de référence, ici B11 à B13, doit être triée dans l'ordre croissant ou alphabétique pour du texte dans le cas contraire la fonction renverra une réponse fausse.

Recherche véctorielle

RECHERCHE (valeur_cherchée,vecteur_recherche,vecteur_résultat)

La forme vectorielle de recherche cherche dans une plage une seule ligne ou colonne (appelée vecteur) pour une valeur et renvoie une valeur à partir de la même position dans une seconde plage à une ligne ou une colonne (Aie ma tête!!!).

Dans cet exemple nous avons un tableau avec des magasins et le CA correspondant, ainsi qu'une table de niveau de CA et des Taux de commissions.

Nous voulons déterminer les taux de commission dans le tableau 1. RECHERCHEV est parfait dans ce cas précis. L'image ci-dessous nous montre le même résultat si nous utilisons =RECHERCHE(C3;$B$11:$B$13;$C$11:$C$13) Colonne D ou =RECHERCHEV(C3;$B$11:$C$13;2) Colonne F.



Sauf que RECHERCHEV ne fontionne que dans un sens, de gauche à droite, et RECHERCHEH de haut en bas, tandis que RECHERCHE ne s'occupe pas de la disposition des colonnes ou des lignes, vous pouvez lier n'importe quelle liste à votre première colonne, du momment qu'elle comporte le même nombre de lignes et qu'elle soit triée dans l'ordre croissant.
Voici ce qui se produit si je déplace la colonne CA de la gauche vers la droite dans la table de référence, RECHERCHEV à perdue le fil, tandis que RECHERCHE est resté correcte.



Comme je l'ai dit plus avant, ce ne sont que deux exemples parmis d'autres, à vous de trouver maintenant dans quels cas utiliser RECHERCHE, nul doute que vous allez maintenant vous poser plus de questions avant d'utiliser RECHERCHEV ou RECHERCHEH.

Si vous avez d'autres exemples ou des compléments d'informations, n'hésitez pas à nous en faire part dans les commentaires ou dans le Forum.

Maîtriser Excel, c'est facile !!!

En discuter sur le Forum?

Print Friendly and PDF


Cet article vous a intéressé, merci de le recommander avec un Google +1 et de le partager sur Facebook, Twitter, Viadeo ou Linkedin, en utilisant les liens mis à votre disposition.

Pour suivre nos prochains articles abonnez-vous au Blog ou inscrivez-vous au flux RSS.

Restez informé, abonnez-vous à la newsletter, entrez votre adresse mail:


Delivered by FeedBurner
Pays/territoire : Bry-sur-Marne, France

0 commentaires :

Enregistrer un commentaire